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Chapter

1
Overview

This document provides a series of step-by-step setup guides to install and integrate a GCC toolchain
within the Eclipse IDE on Microsoft Windows® and Linux. This guide is written with embedded
software development for MCU and SoCs in mind but can be used with any GCC toolchain regardless of
the intended target. Note that there are many combinations of Eclipse versions, plugins and supporting
tools that can be used to successfully build C and C++ applications using the GCC toolchain, this
document is the recommended way by JBLopen but customers are free to modify their development
environment to suit their needs.

The focus of this document is on the Eclipse setup which includes installation and setup of Eclipse and
the chosen toolchain, creation of either a Managed CDT project or a Makefile project and finally how to
create a debug configuration for GDB debugging.

1.1 About Eclipse
Eclipse is a cross-platform IDE that supports multiple programming languages. This document will
mainly use the Eclipse CDT environment for C and C++ code development as well as the GDB
integration offered by Eclipse.
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Chapter

2
Eclipse Setup Guide (Windows)

This section will go over the Eclise IDE and toolchain setup for Windows. Instructions for Linux are
available in the next chapter. The following step-by-step instructions will go through the installation and
configuration of the following components in order:

• MSYS2 – 20200903 – msys2-x86_64-20200903.exe
www.msys2.org

• Eclipse – 2020.06 – eclipse-inst-win64.exe
www.eclipse.org

• GCC - 9-2020q2 - gcc-arm-none-eabi-9-2020-q2-update-win32.zip
https://developer.arm.com/tools-and-software/open-source-software/developer-tools/gnu-
toolchain/gnu-rm

The versions cited above are those that were used when writing this guide. Installation instructions for
newer versions, if available, should be similar.

2.1 MSYS2 Installation
On Windows a basic UNIX environment is required to run the toolchain and more importantly supply
the GNU Make utility. There are multiple options including the well-known Cygwin. This guide will use
MSYS2 since it offers superior build performance and good compatibility with native Windows paths. If
compatible with the host system, the 64-bit version of MSYS2 is recommended, which is labelled
x86_64.

The installation can be started by executing the executable installation file, in this example
msys2-x86_64-20180531.exe, the following screen should appear:
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Figure 1 – MSYS2 installation welcome prompt

Click Next.

Figure 2 – MSYS2 installation directory prompt

Enter the desired installation directory, the installation directory should be short with no spaces in the
path. This guide will assume that the default installation directory of C:/msys64 is used. Click Next.
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Figure 3 – MSYS2 installation start menu shortcut prompt

The installer will now prompt for the name of the start menu shortcut. It is recommended to use the
default name. Click Next.

Figure 4 – MSYS2 installation progress screen

Installation should begin.
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Figure 5 – MSYS2 installation finished screen

The installation should finish successfully. Make sure that ”Run MSYS2 64bit now.” is checked.

Figure 6 – MSYS2 console

The MSYS2 console should open. It is now necessary to perform an update of the MSYS package
manager by typing:

pacman -Syu

And press enter.
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Figure 7 – MSYS2 package manager update prompt

After downloading the update information, a prompt will appear to ask for permission to proceed with
the installation. Type Y and press enter to continue.

Download and installation will proceed, this can take several minutes depending on network connection
and computer performance.

Figure 8 – MSYS2 package update restart request

It is likely that a warning message is displayed at this point asking to return to the shell and restart the
update process. When this occurs exit the MSYS2 console by pressing the X button on the top right
corner of the window. It is important to quit the console that way otherwise the warning may reappear
in the next invocation.
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Figure 9 – MSYS2 window close confirmation

A warning message will be displayed, press OK to proceed with the close.

Open the MSYS2 console again by navigating to the start menu item for MSYS2 and clicking MSYS2
MSYS.

Figure 10 – MSYS2 start menu entry

Once opened type:

pacman -Su

And press enter to continue the update process.
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Figure 11 – MSYS2 package manager update prompt

A prompt asking for permission to continue will appear again. Type Y and press enter to continue.

Download and installation will proceed, like the previous step this can take several minutes depending
on network and computer performance.

Installation should complete without any error or warning messages.

Figure 12 – MSYS2 package manager update done

With the package manager updated and synced it is time to install the basic development utilities. This
can be achieved by typing:

pacman -S base-devel

A list of packages to be installed will appear.
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Figure 13 – MSYS2 base-devel prompt

Press Enter to continue.

Figure 14 – MSYS2 base-devel installation confirmation prompt

Type Y and then Enter to continue.

Download and installation will proceed, this can take several minutes depending on network and
computer performance.
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Figure 15 – MSYS2 base-devel installation completed

The installation should complete without any error or warning messages.

To test that the installation is functional, let’s run a simple test by invoking the make utility as such:

make -v

The make utility should output its version information in the console.

Figure 16 – MSYS2 make test output

MSYS2 and the required utilities are now installed, the console window can be closed.

GCC Toolchain Eclipse Setup Guide www.jblopen.com

https://www.jblopen.com


� �

�������
�	
������
�������������� Chapter 2 Eclipse Setup Guide (Windows) 11

2.2 Eclipse Installation
The next package to install is the Eclipse IDE. Start by executing the installer file. Note that if possible
the 64-bit version of Eclipse is strongly recommended. In this example eclipse-inst-win64.exe,
the following screen should appear.

Figure 17 – Eclipse install screen

Select ”Eclipse IDE for C/C++ Developers” by clicking it. The install configuration screen should appear.
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Figure 18 – Eclipse installation configuration dialog

The Product Version should be set to latest unless a specific version of Eclipse is desired. Right next to
the version is the selection for 32 or 64-bit. 64 Bit is strongly recommended if it is supported by the
host computer. Next is the Java virtual machine selection. If a suitable JVM is found, it will usually be
selected. Note that the JVM must match with the 32 or 64-bit selection. For the installation directory, it
is recommended to use a unique directory that is short with no spaces in the name as the eclipse install
directory. In this example we will use C:/eclipse_gcc” as the install directory. The eclipse installer
will automatically create an eclipse subdirectory inside the specified installation path. Finally, it is
possible to create a start menu entry and/or a desktop shortcut if desired.

Click install to continue.

GCC Toolchain Eclipse Setup Guide www.jblopen.com

https://www.jblopen.com


� �

�������
�	
������
�������������� Chapter 2 Eclipse Setup Guide (Windows) 13

Figure 19 – Eclipse installation licence dialog

The licence confirmation prompt should appear. Click ”Accept” to continue.

Figure 20 – Eclipse installation progress dialog

The installation should progress. This may take some time depending on network performance.
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Figure 21 – Eclipse certificate trust prompt

The installer will likely prompt to trust of the remote server certificate where the Eclipse files will be
downloaded. Check the checkbox next to the certificate name and click accept selected.

Installation should proceed.
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Figure 22 – Eclipse installation complete and launch prompt

Launch the installation to check if it’s working properly and create the first workspace. Do so by clicking
Launch.

The workspace selection prompt should appear.

Figure 23 – Eclipse workspace selection prompt

It is strongly recommended to create a unique workspace that will be used exclusively for the projects
related to the GCC toolchain that will be installed in this guide. The workspace selected should not have
a path name that is excessively long and it is recommended not to use spaces in the path name either.
To keep everything well contained and ordered this example will use
C:/eclipse_gcc/eclipse_workspace as the workspace.
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Click Launch.

The Eclipse welcome screen should appear.

Figure 24 – Eclipse welcome screen

Eclipse can be closed at this point as there are more packages to install before setting up the Eclipse IDE.

2.3 Toolchain Installation
This guide will use as an example the GNU Embedded Toolchain for Cortex-R and M distributed by
ARM. However the procedure should be very similar to other embedded GCC toolchains. On Windows,
if given a choice a simple ZIP or tarball archive is easier than an executable installer, this guide will use
the former as an example.

To install the toolchain it should simply be extracted to a suitable directory. As usual the full directory
path should be short with no spaces. This example will use C:/eclipse_gcc/gcc.

The installation can be tested by opening a windows command prompt, changing the directory to the
bin subdirectory of GCC installation directory and running the gcc executable. The full name of the GCC
executable will be prefixed by the target triplet. For example arm-none-eabi-gcc.exe

After finding the name of the GCC executable, it can be executed as follows:

arm-none-eabi-gcc.exe -v
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GCC should output various versions and build information to the command prompt.

Figure 25 – GCC version information

2.4 Environment Variable Setup
For the toolchain to be easily accessible by Eclipse, Make and other utilities it is preferable to have the
toolchain binary location in the PATH environment variable.

One can notice that they are usually two bin directories available within a GCC toolchain distribution.
One directory contains all of the toolchain’s executables prefixed with the target triplet, i.e.
arm-none-eabi-gcc.exe while the other contains generic names without the host triplets. When
adding the toolchain to the PATH environment variable, it is important to use the directory where the
executables are prefixed with the target triplet. First the other directory doesn’t contain all the
necessary executables, but may interfere with the OS native toolchain.

2.4.1 PATH Environnement Variable Setup
Start by opening the Windows Control Panel.
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Figure 26 – Windows Control Panel

Click ”System”.

Figure 27 – Windows system settings

Click ”Advanced System Settings”.
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Figure 28 – Windows Advanced System Settings

Click ”Environment Variables”.
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Figure 29 – Windows environnement variable configuration panel

In this screen, if an existing PATH environment variable exists, click it and then click ”Edit...” otherwise
click ”New...”

Figure 30 – Windows new environment variable dialog

Two paths should be added either to the existing PATH variable or the new one. The usr/bin
subdirectory of the MSYS2 installation and the bin subdirectory of the GCC installation. For the install
directories chosen for this example, this results in the following two paths:

C:/msys64/usr/bin;C:/eclipse_gcc/gcc/bin;

Then click OK.
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Figure 31 – Configured environment variables

Then OK again to exit the Environment Variables window.
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Chapter

3
Eclipse Setup Guide (Linux)

This section will go over the Eclise IDE and toolchain setup for Linux. Instructions for Windows are
available in the previous chapter. The following step-by-step instructions will go through the installation
and configuration of the following components in order:

• Eclipse – 2020.06 – eclipse-inst-linux64.tar.gz
www.eclipse.org

• GCC - 9-2020q2 - gcc-arm-none-eabi-9-2020-q2-update-x86_64-linux.tar.bz2
https://developer.arm.com/tools-and-software/open-source-software/developer-tools/gnu-
toolchain/gnu-rm

The versions cited above are those that were used when writing this guide. Installation instructions for
newer versions, if available, should be similar.

3.1 Eclipse Installation
The first package to install is the Eclipse IDE. As is usual with Linux, there’s more than one way to install
Eclipse. This guide will use the official Eclipse installer from eclipse.org which will install Eclipse within
the current user’s home directory. This is the simplest method and is also useful since it isolates the
Eclipse installation from any native installation that may exist.

Start by extracting the installation archive and executing the installer file. Note that if possible the
64-bit version of Eclipse is strongly recommended. In this example eclipse-inst, the following
screen should appear.
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Figure 32 – Eclipse install screen

Select ”Eclipse IDE for C/C++ Developers” by clicking it. The install configuration screen should appear.
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Figure 33 – Eclipse installation configuration dialog

Set the installation directory, it is recommended to use a unique directory that is short with no spaces in
the name as the eclipse install directory. In this example we will use /home/jblopen/eclipse as the
installation directory. The eclipse installer will automatically create an eclipse subdirectory inside the
specified installation path.

Click install. Installation should start and a progress bar should be displayed.
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Figure 34 – Eclipse installation progress dialog

Installation should proceed.
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Figure 35 – Eclipse installation complete and launch prompt

Launch the installation to check if it’s working properly and create the first workspace. Do so by clicking
Launch.

The workspace selection prompt should appear.

Figure 36 – Eclipse workspace selection prompt

It is strongly recommended to create a unique workspace that will be used exclusively for the projects
related to the GCC toolchain that will be installed in this guide. The workspace selected should not have
a path name that is excessively long and it is recommended not to use spaces in the path name either.
To keep everything well contained and ordered this example will use
/home/jblopen/eclipse-workspace as the workspace.
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Click Launch.

The Eclipse welcome screen should appear.

Figure 37 – Eclipse welcome screen

Eclipse can be closed at this point as there are more packages to install before setting up the Eclipse IDE.

3.2 Toolchain Installation
This guide will use as an example the GNU Embedded Toolchain for Cortex-R and M distributed by
ARM. However the procedure should be very similar to other embedded GCC toolchains.

First the downloaded toolchain archive should be extracted to a suitable location. In this example we
will create a directory named gcc in the current user home directory and then extract the toolchain into
that directory. This can be done, for example, by executing the following commands from the directory
that contains the downloaded archive.
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$ mkdir ~/gcc
$ tar -xvf gcc-arm-none-eabi-9-2020-q2-update-x86_64-linux.tar.bz2 -C ~/gcc/

That’s about it for the toolchain installation on Linux. Optionally, the toolchain can be added to the
PATH variable as shown in the next section.

3.3 GNU Make Installation
In addition to the toolchain and Eclipse it is usually necessary to at least have the GNU Make utility to
process makefiles. This utility may already be installed, if not there’s usually a package containing the
minimal set of applications required to build.

Under Debian, Ubuntu and many others one can simply install the build-essential package. For
example by running the following command:

$ sudo apt-get install build-essential

3.4 PATH Environment Variable Setup
It is not necessary to add the toolchain to the PATH environment variable to use the newly installed
toolchain in Eclipse. However, it can be useful for building directly from the command line.

One can notice that they are usually two bin directories available within a GCC toolchain distribution.
One directory contains all of the toolchain’s executables prefixed with the target triplet, i.e.
arm-none-eabi-gcc while the other contains generic names without the host triplets. When adding
the toolchain to the PATH environment variable, it is important to use the directory where the
executables are prefixed with the target triplet. First the other directory doesn’t contain all the
necessary executables, but may interfere with the OS native toolchain.

To add the toolchain to the PATH, add or edit the following line of the .bashrc file located in the home
directory of the current user. It’s usually a good idea to add it to the end of the list to prevent conflicts.

export PATH=$PATH:/home/jblopen/gcc/gcc-arm-none-eabi-9-2020-q2-update/bin

When updating the PATH variable like this Eclipse will not see the new toolchain if Eclipse is launched
from the desktop environment. This can be fixed by launching Eclipse from the command line, for
example:
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$ nohup ./eclipse &

Additional methods of adding the toolchain to Eclipse are discussed in the management and makefile
build projects chapters of this guide.
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Chapter

4
Eclipse Managed Build Project
Setup

There are two main types of CDT projects that can be used in Eclipse. The first one is called a managed
build where Eclipse CDT will manage the build. The other option is a Makefile project where a
user-supplied Makefile is used with little help from Eclipse. Both methods have their pros and cons and
this guide covers both.

This chapter will go over the basic steps required to create and set up a managed build project using the
toolchain and Eclipse installation done in the first chapter. Note that this guide will not go over the
project configuration for specific MCU or SoC as these settings can vary wildly and are beyond the
scope of this guide.

4.1 Workspace Setup
Not much configuration is required at the workspace level when using a managed build, but it’s a good
idea to see if Eclipse has detected the toolchain that was added to the system PATH environment
variable earlier in this guide. Note that the toolchain will only appear if it was added to the PATH
variable.

First launch Eclipse if it’s not already started. The workspace selection prompt should appear.

Figure 38 – Eclipse workspace selection prompt
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If a workspace was created during the Eclipse installation select it, otherwise create it now. It is strongly
recommended to create a unique workspace that will be used exclusively for the projects related to the
GCC toolchain that will be installed in this guide. The workspace selected should not have a path name
that is excessively long and it is recommended not to use spaces in the path name either. To keep
everything well contained and ordered this example will use C:/eclipse_gcc/eclipse_workspace
as the workspace.

Click Launch.

The Eclipse welcome screen should appear.

Figure 39 – Eclipse welcome screen

The welcome screen can be closed by pressing the X next to the Welcome tab. This reveals the main
Eclipse view, which should be empty if this is a new workspace.
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Figure 40 – Eclipse main view

Open the workspace preferences by clicking the Window->Preferences menu entry.

Figure 41 – Eclipse workspace preferences menu entry

Navigate to the ”Core Build Toolchains” subsection of the ”C/C++” section of the Preferences panel.
This should display a list of detected toolchains. If the toolchain was installed correctly and was added
to the PATH environment variable, it should appear in the list.
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Figure 42 – CDT Core Build Toolchains

In this example the toolchain for ARM installed earlier was detected with the path to the main GCC
executable being C:/eclipse_gcc/gcc/bin/arm-none-eabi-gcc.exe correctly displayed.

That is all the workspace level items of importance for a managed build. The next step is to create the
managed build project proper.

4.2 Managed Build Project Setup
To create a new managed build project select the File->New->C/C++ Project entry from the File Menu.

Figure 43 – New C/C++ Project menu entry
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In the New C/C++ project dialog select ”C Managed Build”.

Figure 44 – New C/C++ Project Dialog

Click Next. In this next screen, the project name and location should be set as well as the toolchain.
Type a name for the project, for example ”ex_managed_build” and select a location. If the ”Use default
location” box is checked the project will be created inside the current workspace, otherwise a directory
can be typed or selected using the ”Browse” button. As usual it is recommended to keep the project
path short without any spaces.

It is also important to select an empty executable project along with the ”Cross GCC” toolchain as
displayed in the following screenshot.
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Figure 45 – New C/C++ Project name and toolchain selection

Click Next. The Select Configurations dialog will display.
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Figure 46 – Project Configurations dialog

There is nothing to change on this screen other than clicking next.

The next ”Cross GCC Command” dialog is rather important, this is where we select the toolchain to use
for building. To do so it’s necessary to type in the prefix of the GCC toolchain. Most of the time all the
executables from a GCC cross compiler will be prefixed with a target triplet . For example, in our
ARMv7 toolchain the target triplet is arm-none-eabi and the full prefix is ”arm-none-eabi-”. The full
prefix should be typed in the ”Cross Compiler prefix:” box. If the toolchain was added to the PATH
environment variable, it is not necessary to enter the path to the toolchain. Otherwise the toolchain bin
directory should be entered.
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Figure 47 – Cross GCC Command dialog

Click Finish. The project should now be created and available in the workspace.

Figure 48 – Eclipse main view with new project

Files can now be added and the build settings set for the particular target for the project. The exact
settings are outside the scope of this guide but let’s at least add a simple main file to test the build.

To add a new file right-click on the project, or select the project and click the Project->New->Files menu
item.
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Figure 49 – Project new file menu entry

Type ”main.c” in the ”Create New File” Dialog and click ”Finish”.

Figure 50 – Create new file dialog
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Let’s fill the new source file with a minimal C main function.

Figure 51 – C Main function

If you try building the minimal C program, it’s quite likely that an error similar to the following linker
error is displayed.

exit.c:(.text.exit+0x2c): undefined reference to `_exit'

To fix that common issue --specs=nosys.specs must be added to the linker command-line options.
Note that if the error doesn’t happen it is important not to add the linker option.

To add the option first open the project properties, by right-clicking on the project or by selecting the
project and click the Project->Properties menu entry.

Figure 52 – Project Properties menu item
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Navigate to the ”Miscellaneous” category under ”Cross GCC Linker” and add the option to the ”Linker
flags” box.

Figure 53 – Project linker configuration

At this point the minimal program should build and everything is set up to start development of an
embedded project using the chosen toolchain.
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Chapter

5
Eclipse Makefile Project Setup

The second type of Eclipse project, a Makefile project, is more complicated to setup but offers greater
control and flexibility over the build process. A Makefile based project is also independent of Eclipse
and can be built and maintained easily outside of Eclipse. This can be useful for automated builds.

5.1 Workspace Setup
Some configuration is helpful at the workspace level when using a Makefile build, it is also a good idea
to see if Eclipse has detected the toolchain that was added to the system PATH environment variable
earlier in this guide.

First launch Eclipse if it’s not already started. The workspace selection prompt should appear.

Figure 54 – Eclipse workspace selection prompt

If a workspace was created during the Eclipse installation select it, otherwise create it now. It is strongly
recommended to create a unique workspace that will be used exclusively for the projects related to the
GCC toolchain that will be installed in this guide. The workspace selected should not have a path name
that is excessively long and it is recommended not to use spaces in the path name either. To keep
everything well contained and ordered this example will use ”C:/eclipse_gcc/eclipse_workspace” as the
workspace.
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Click ”Launch”.

The Eclipse welcome screen should appear.

Figure 55 – Eclipse welcome screen

The welcome screen can be closed by pressing the X next to the Welcome tab. This reveals the main
Eclipse view, which should be empty if this is a new workspace.
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Figure 56 – Eclipse main view

Open the workspace preferences by clicking the Window->Preferences menu entry.

Figure 57 – Eclipse workspace preferences menu entry

Navigate to the ”Core Build Toolchains” subsection of the ”C/C++” section of the Preferences panel.
This should display a list of detected toolchains. If the toolchain was installed correctly and was added
to the PATH environment variable, it should appear in the list.
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Figure 58 – CDT Core Build Toolchains

In this example the toolchain for ARM installed earlier was detected with the path to the main GCC
executable being C:/eclipse_gcc/gcc/bin/arm-none-eabi-gcc.exe correctly displayed.

Next it is helpful to change the Cross GCC compiler settings discovery for Eclipse CDT. This while help
with some indexing issue later. To do so navigate to the ”C/C++->Build->Settings” section of the
Preferences panel and open the ”Discovery” tab.
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Figure 59 – CDT Discovery Settings panel

Click the ”CDT Cross GCC Built-in Compiler Settings” item from the list. The ”Command to get compiler
specs:” box should be modified to add the toolchain prefix in front of the command. In our example
”arm-none-eabi-”.

The result should look as follows:
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Figure 60 – Modified CDT Cross GCC Built-in Compiler Settings

That is all for the workspace configuration, click ”Apply and Close” to apply and save the configuration.

5.2 Alternative Workspace Specific PATH Variable
If the toolchain is not accessible through the default environment PATH variable, it is possible to either
add it to the workspace specific environment variables or to each project’s environment. This section
will go over the workspace environment while the project specific method is discussed in the next
section.

First navigate to the workspace preferences by selecting the Window->Preferences menu item. This will
open the preferences panel. From that panel select the C/C++ -> Build -> Environment from the left
panel. This will display the workspace environment variable settings.
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Figure 61 – Workspace environment variable configuration panel

Make sure that the ”Append variables to the native environment” option is checked.

Click Add. In the new dialog enter PATH as the name and the full path to the desired toolchain bin
directory. Note that since Eclipse will append the variables added in this configuration panel to the
native environment it’s important not to add the usual $PATH reference.

Figure 62 – Workspace environment variable configuration Add/Edit Variable dialog

Click OK.
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Figure 63 – New variable added

Click ”Apply and Close”, Now every new project built within the current workspace will have the
toolchain path within the PATH environment variable.

5.3 Makefile Project Setup
When creating a new Makefile project, it is advisable to create it in a directory that already contains at
least an empty Makefile. This is to ensure that the correct project type and nature are set when creating
the project. The makefile should be named either ”makefile” or ”Makefile” with a capital M.

For this example we’ll use a directory named ”ex_make_build” for the project with an empty Makefile
named ”makefile”.

To create a new Makefile project select the File->New->Makefile Project With Existing Code menu entry
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Figure 64 – New Makefile project menu item

This should open the New Project dialog. Browse or type the path to the existing makefile created
earlier or you source code to build. By default the project name is the same as the directory name but
can be changed if desired. Finally, select ”Cross GCC” as the toolchain.

The C and C++ checkboxes can be used to enable disable indexing of C++ or C code. If either of those
will be found in your project, the corresponding box should be checked.
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Figure 65 – New Makefile Project dialog

Click Finish. Eclipse will return to the main view with the newly created project in the workspace.
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Figure 66 – Eclipse main view with new project

Let’s add a file to build named main.c with a minimal main function. To do so right-click on the project
then click the New->file menu item.

Figure 67 – Project new file menu item

In the ”Create New File” dialog enter the name of the file, ”main.c” in this example.
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Figure 68 – New File dialog

At this moment if a C or C++ include directive of a standard header is written in the C file, it will most
probably be underlined stating that there is an unresolved inclusion. This is due to the CDT indexer
being unable to invoke the cross compiler.

Note that if you have a native GCC compiler available in your environment PATH it might be used by
default for indexing. In which case there won’t be unresolved inclusions reported by the indexer.
However, since these headers do not match the current toolchain it can cause a few issues with code
completion and indexing.
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Figure 69 – Example of an unresolved inclusion

To fix this issue open the Project Properties, either by right-clicking on the project or selecting the
project and opening the Project->Properties menu item.

Figure 70 – Project Properties menu item

In the Properties panel navigate to the ”Preprocessor Include Paths, Macros etc.” section of the ”C/C++
General” category.
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Figure 71 – C/C++ Providers Settings

Assuming that the workspace setup was done, on this screen select the ”CDT Cross GCC Built-in
Compiler Settings” item and check the ”Use global provider shared between projects” checkbox. This
will change the provider’s configuration to the one we set in the workspace.
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Figure 72 – Modified C/C++ Providers Settings

At this point the include files should no longer be unresolved.

Now that the inclusions are fixed, we need a Makefile. Here is a minimal example Makefile:

# Intermediary objects working directory.
OBJDIR := obj

# Name of the output binary executable file.
LINK_TARGET := a.out

# Application source files list.
APP_SOURCE := main.c

# Name of toolchain executables to use.
CC := arm-none-eabi-gcc
AS := arm-none-eabi-gcc
AR := arm-none-eabi-ar
LD := arm-none-eabi-gcc

# C Build flags.
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C_FLAGS := -mcpu=cortex-m4 -g -ffunction-sections --specs=nosys.specs

# C Build warning flags.
WARNING_FLAGS := -Wall -pedantic -Wconversion

# Configure include directories.
INCLUDEDIR = $(subst \,/,$(PWD)) \

$(BSP_SRC_DIR) \

# Extract all the C source file names.
SOURCE += $(notdir $(APP_SOURCE))

# Compute intermediary object names.
OBJ += $(SOURCE:%.c=$(OBJDIR)/%.o)

# Build everything.
all : $(OBJDIR) $(LINK_TARGET)

@echo All done

# Firmware binary linking.
$(LINK_TARGET) : $(OBJ)

$(LD) -o $@ $^ $(C_FLAGS)

# C files build.
$(OBJDIR)/%.o : %.c | $(OBJDIR)

$(CC) $(C_FLAGS) $(WARNING_FLAGS) -o $@ -c $<

$(OBJDIR) :
mkdir $(OBJDIR)

.PHONY: clean
clean:

rm -rf ${OBJDIR}
rm -rf $(LINK_TARGET)

The project can now be built using the ”Build Project” item from the context menu.
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Figure 73 – Build Project menu item

The Makefile project is now ready for development.
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Figure 74 – Built project

5.4 Project Specific Toolchain Path
The previous instructions assumed that the toolchain was reachable through the build environment’s
PATH variable. If the toolchain path wasn’t added to the eclipse environment or not added through the
workspace environment settings then it must be added to the project environment itself.

This can be achieved by opening the project’s properties and navigating to the C/C++ Build ->
Environment panel.
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Figure 75 – Project build environment configuration panel

An existing PATH variable is most probably already defined from the build environment. Click edit to
modify it.

Figure 76 – Edit build environment variable dialog

In the edit dialog append the path to the toolchain bin directory at the end of the existing paths by
adding a colon followed by the path.
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Click OK.

Figure 77 – PATH variable edited

Click Apply and Close.

At this point the toolchain should be usable from this specific project. These last steps must be repeated
for each individual projects when using this method.

5.5 Indexing External Source Files
Oftentimes when using a Makefile project it is desirable to build source files that are outside the project
directory. In that situation the indexer may not be able to find those files automatically which leads to
unresolved inclusions warnings, code-completion issues and difficulty with debugging.

Figure 78 – Unresolved inclusion of an external file
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For example, in the previous screenshot the external include file uart/bp_uart.h is underlined in
yellow, meaning it hasn’t been found by the indexer.

To solve this problem the path to the source files must be added in two locations. To do so open the
project Properties and navigate to the ”Paths and Symbols” On that screen open the ”Source Location”
tab. If it is not displayed use the arrows on the right which will show any hidden tabs on this panel.

Figure 79 – Project Source Location configuration

To add a new external source location click ”Link Folder”.

Figure 80 – Link directory dialog
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Check the ”Link folder in the file system” box and then browse or type the location of the external
source. In this example the external source code location is the ”C:/ip_dev/base_platform” directory.
Click OK to add the directory.

Once the source location is linked, it is necessary to add the location to the indexer’s include path. To do
so open the ”Includes” tab. And select either GNU C or GNU C++ depending on your project type.

Note that in the case both C and C++ was selected when initially creating the project, CDT will use the
C++ compiler for indexing. In this case it’s important to add the include files paths to the GNU C++
language and note GNU C.

Figure 81 – Includes configuration panel

Click ”Add...” to add a new directory to search for include files. This will open the ”Add directory path”
dialog. Since the source location was linked in the previous steps, it’s possible to use the workspace link
in this dialog.

Figure 82 – Add directory path dialog
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Click ”Workspace...” to add a workspace location.

Figure 83 – Add workspace path dialog

Select the previously created workspace link, in this example ”base_platform”. Then click OK to add the
path.

After doing the procedure for each external source location, they should be properly indexed and
reachable during a debugging session.
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Debug Configuration

Many debug probes and targets supports acting as a GDB server. Which means that they can be
debugged using GDB either remotely or from the same host. The exact steps required to start a GDB
server are outside the scope of this guide but once the GDB server is running it’s easy to connect
through it from Eclipse. This guide assumes that the GDB server is started on the local host, in which
case it’s important to note the port number in use by the GDB server. The port number is usually
prominent in the server configuration if a GUI tool was used to start the server. Otherwise the port
number is usually specified on the command line when starting gdbserver from a shell.

First open the ”Debug Configurations” menu by right-clicking on the project and selecting the ”Debug
As->Debug Configurations” menu entry. It’s recommended to use this method to open the ”Debug
Configurations” dialog as it will make it easier to create a new debug configuration for the project.
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Figure 84 – Debug Configurations menu item

This will open the ”Debug Configurations” panel.

Figure 85 – Debug Configurations panel

Right click on ”GDB Hardware Debugging” and select ”New Configuration”.
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Figure 86 – Debug Configurations context menu

This will create and populate a new debug configuration for the selected project. Eclipse CDT will
attempt to guess the name of the executable file. Check that the content of the ”C/C++ Application”
box match the target executable to debug.

Figure 87 – Newly created debug configuration
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Open the ”Debugger” tab for further configuration.

Figure 88 – Debugger configuration

In this panel the host name and port number of the GDB server should be entered. If the server was
started on the local host then locahost can be entered or ’127.0.0.1’. The port number should be the
same as the one used when launching the GDB server. In most cases this is sufficient for a debug
configuration to work.

Click ”Debug” to launch the configuration.

Figure 89 – Confirm Perspective Switch dialog
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The perspective switch confirmation dialog usually appears to warn the user that the view will be
switched to the debugging view. Using the ”Remember my decision” checkbox will prevent this dialog
from appearing further.

Figure 90 – Debug session

And from this point everything should be ready to build and debug your embedded project using Eclipse.
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